PHPをバージョンアップします。
アップデートバージョンはPHP 5.2.8です。
PHP 5.2.6、PHP 5.2.7と立て続けに脆弱性が見つかっているので早めにアップデートしましょう。

$ wget http://jp.php.net/get/php-5.2.8.tar.bz2/from/this/mirror
$ tar xvjf php-5.2.8
$ cd php-5.2.8
$ ./configure --with-apxs2=/usr/local/apache2/bin/apxs \
              --with-mysql=/usr/local/mysql \
              --with-zlib \
              --with-gd \
              --with-jpeg-dir=/usr/lib \
              --enable-mbstring \
              --enable-mbregex \
              --disable-ipv6
$ make
# make install

Apacheを再起動します。

# /sbin/service httpd restart
httpd を停止中:                                            [  OK  ]
httpd を起動中:                                            [  OK  ]

見た目には成功のように見えましたが、エラーログが出ていてApacheが起動していませんでした。
/var/log/httpd/error.log

PHP Warning:  [eAccelerator] This build of "eAccelerator" was compiled for PHP version 5.2.6. Rebuild it for your PHP version (5.2.8) or
download precompiled binaries.\n in Unknown on line 0
PHP Fatal error:  Unable to start eAccelerator module in Unknown on line 0

eAcceleratorをPHP 5.2.8でコンパイルする必要があります。

$ tar xvjf eaccelerator-0.9.5.2.tar.bz2
$ cd eaccelerator-0.9.5.2
$ phpize
$ ./configure
$ make
# make install

もう一度Apacheを再起動します。

# /sbin/service httpd restart
httpd を停止中:                                            [  OK  ]
httpd を起動中:                                            [  OK  ]

今度は成功しました。